Install error: rendered manifests contain a resource that already exists

Hi there,

I'm getting the following error while installing maesh. I have already tried to delete the CustomResourceDefinition via kubectl delete before installation. Unfortunately without success.

root@ubuntu:/# helm install maesh maesh/maesh
Error: rendered manifests contain a resource that already exists. Unable to continue with install: existing resource conflict: kind: CustomResourceDefinition, namespace: , name: traffictargets.access.smi-spec.io

Any suggestions?

Hello @and,

There were some conflicts that users could have encountered with v1.0.0 due to mismatching helm and chart versions.

As of v1.1.0, the helm chart is for helm v3, and the CRD are managed separately now, via helm.

There is a note in the documentation about the CRDs (https://docs.mae.sh/v1.1/install/#service-mesh-interface) , in that you can skip their install via the --skip-crds helm flag.

Please let us know if this works for you.

1 Like

Hey @daniel.tomcej

Thanks for your answer. I had some time at the end of December to take a closer look at various things, including Maesh. I don't know if I'll get back to it now but the project definitely has my attention in the future and I'm looking forward to it. Keep up the good work.